4/11/09

Altes Firefox-Plugin unter neuerer Version

Wer so wie ich den TinyTinyRSS Reader für seine Feeds benutzt in Zusammenhang mit dem Firefox-Plugin TT-RSS Notifier, hat seit dem Update auf Ubuntu Karmic Koala 9.10 ein Problem mit diesem Plugin. Denn in der install.rdf steht das dieses Plugin nur für die Firefox-Version 3.0.* ausgelegt ist, da aber mit dem Update von Karmic Firefox 3.5.4 mitkommt funktioniert dieses Plugin nicht mehr.

Mittlerweile habe ich mich an dieses Plugin allerdings schon so gewöhnt, dass ich es nicht missen möchte, da es aber noch keine neue Version für Firefox 3.5.* gibt musst eine andere Lösung her. Gesucht und gefunden man sucht sich die Datei install.rdf in seinem Dateisystem welche für den Notifier zuständig ist.

Pfad bei mir: home/name/.mozilla/firefox/nummer.default/extensions/ttrssnotifier@rick.jinlabs.com/install.rdf

Diese install.rdf nun mit einem Editor öffnen und em:maxVersion=”3.0.*” um ändern auf em:maxVersion=”3.5.*” .

Anschließend Firefox neustarten und schon verrichtet der Notifier wieder seine Arbeit.

Autor: Christoph

IT mit Herz und Seele. Interessiert sich für fast alles wofür Technical-Life steht und hat hier Anfangs an den Mühlen gedreht. Serienjunkie aus Überzeugung. Twitter: @technicallife

Linux, Technik, Ubuntuusers , , ,

4 Kommentare

  1. Wäre schön wenn der Firefox bei Erweiterungen, die für eine andere Version gemacht wurden, nur warnt, anstatt die Installation und Verwendung komplett zu verweigern. In viele Fällen funktionieren die Erweiterungen schließlich trotzdem mit der neuen FF-Version einwandfrei.

  2. Andere Möglichkeit, bei der man nichts an den Dateien ändern muss: Den Kopatibilitätstest von Firefox deaktivieren.

    1. about:config im Firefox öffnen
    2. Eine neue Einstellung vom Typ Boolean mit dem Namen extensions.checkCompatibility erstellen
    3. Den Wert der neuen Einstellung auf false setzen

Hinterlasse eine Antwort

Pflichtfelder sind mit * markiert.